Saturday, September 05, 2009

SageTV/Sage HD200 and Windows Server 2008

OS: Windows Server 2008 SP2 x64

Clean install of SageTV.
Note: Setup SageTV service to interact with desktop to get the SageTv service running.

Installed latest HDHomerun Drivers(20090930)

Used(with some edits) this BDA install:
BDA (TV Tuner) support for Server 2008 x86 and x64

Need to setup Desktop Experience in W2K8


Process:

When setting up the QAM channels with HDHomerun, the scan/channel find worked. I used VLC to view channels and it worked great; using the built-in HDHomerun viewer, no video.

Note: The HDHomerun software would not save the .scn files, so I run the same on my current setup to create new channel .scn files(some new stations showed up) and copied the 4 channel .scn files to my new SageTV install on 2008.

Running the SageTV setup; it displays the HDHomerun tuners; allows me to select as Digital tuner/select cable system; But, SageTV is not seeing the HDHomerun .scn file, the .scn channels are not loading. And when I Preview a Channel, I get 0 signal strength.

Tried for 3hours to figure out how to get SageTV see the HDHomerun .scn files. It Didn't.

So.

I copied a large number of tuner lines from the Sage.properties file on my working system(XP) to the Sage.Properties file my new system(w2k8 x64), I also copied the HDHomerun .frq files from the working system to the new system.

Started up SageTv on the new W2K8 x64 system and bam..I got video.

This confirms everything is setup right, but something is screwed in SageTV's setup process and it is not seeing the HDHomerun .scn files. (I seem to remember the same thing happening last month even on the XP system, took me 5 hours to get it working again).


Next I tested the Sage HD200, it Passed! Live College Football in HD looked Great.

I had to redo the standard setup on the Sage HD200, as it's now connecting to a new server.

I then setup recording 4 different channels on the new SageTv server using the HD200, seems to be working. (I have 2 HDHomeruns/2 tuners each)

Now to finish setting up the SageTV server; Hope I can get commercial skipping, auto compressing files, tweeting and sage web app working again.


Why did I do this?

I have the W2K8 server running 24/7; figured better to shutdown my HTPC & save some money on electric service.

After testing the HD200/HDMI/BigScreen, it seemed time to try this before the new tv season starts up.

I can RDC to the W2K8 in the basement, if I need to do anything 'local' to the Sage software.


Last; Wish I could figure out how to get the SageTV software to see the .scn files


Hope this post may help someone in the future.

1 comment:

Brent Evans said...

Have you reported your problem with the scn file to SageTV support? It definitely should "see" those .scn files from the HDHR setup.

I'm using the XP version of SageTV, but it worked for me. They've made many changes to the tuner setup w/ SageTV in the last few versions so that could be somehow related to the issues you were seeing.